PHP
ProductVulnerabilities
2 CVEs in our records, 2 known exploited (on CISA's KEV list).
- CVE-2026-109618 Exploited added to KEV 26 Oct
- CVE-2026-109619 Exploited added to KEV 26 Oct
Am I affected?
Checked against NVD affected-version data on our server. Nothing you type is stored.
Affected versions
- CVE-2026-109619 from 8.5.0, before 8.5.12 · fixed in 8.5.12
- CVE-2026-109619 from 5.4.0, before 8.2.35 · fixed in 8.2.35
- CVE-2026-109619 from 8.3.0, before 8.3.36 · fixed in 8.3.36
- CVE-2026-109619 from 8.4.0, before 8.4.27 · fixed in 8.4.27
- CVE-2026-109618 from 7.3.0, before 8.2.35 · fixed in 8.2.35
- CVE-2026-109618 from 8.3.0, before 8.3.36 · fixed in 8.3.36
- CVE-2026-109618 from 8.4.0, before 8.4.27 · fixed in 8.4.27
- CVE-2026-109618 from 8.5.0, before 8.5.12 · fixed in 8.5.12
End of support
- PHP 8.2: security support ends 31 December 2026 (vendor)
Security timeline
- Vulnerability reported by Debian Security AdvisoriesDebian issues vim security update fixing 40 vulnerabilities
- Vulnerability reported by Federal News Network (Cybersecurity)CISA official criticises Chainguard for releasing a PHP bug early
- Vulnerability reported by SecurityWeekPHP2Shell attacks root Palo Alto firewalls but fail against WordPress
- Vulnerability reported by NCSC (UK)Critical PHP flaws CVE-2026-109618 and CVE-2026-109619 now exploited in the wild
- Vulnerability reported by Qualys Threat ResearchCISA adds Brotli and Adobe Commerce PolyShell flaws to Known Exploited Vulnerabilities catalogue
Recent news
October 2026 roundup lists cyberattacks on Binance, PHP, Node.js, LiteLLM and the Pentagon
A roundup of October 2026 security incidents covers a cryptocurrency platform, developer infrastructure, certificate authorities, government records, gaming accounts and retail operations. The headline names Binance, PHP, Node.js, LiteLLM and the Pentagon, but the excerpt is truncated and gives no details of the attacks. The article notes that confirmed breaches, malicious releases, vulnerable configurations and possible credential exposure need separate handling.
Debian issues vim security update fixing 40 vulnerabilities
Debian advisory DSA-6600-1 covers 40 CVEs in Vim, spanning path traversal in the tar and zip plugins, buffer overflows and underflows, out-of-bounds reads and writes, crashes, and command or code injection. Several issues are reachable through netrw, NetBeans, completion, spell files and tag files, so the risk comes from opening untrusted content. Systems running Vim should install the Debian update.
CISA official criticises Chainguard for releasing a PHP bug early
Chainguard reportedly broke an embargo by releasing details of a critical PHP vulnerability early. A CISA official described the move as dangerous, arguing that AI is adding to the pressures facing cyber defenders.
AO3 fanfiction archive offline for weeks after security incident
The Organization for Transformative Works, which runs Archive of Our Own (AO3), says a security incident has taken the site down for maintenance. Restoration is estimated at about two weeks and could take up to a month. The operator says it does not expect any data loss, and it has ruled out a link to the recent PHP security issue because AO3 runs on Ruby on Rails.
PHP2Shell attacks root Palo Alto firewalls but fail against WordPress
Critical PHP vulnerabilities, referred to as PHP2Shell, have been targeted in attacks for over a week. The attacks have gained root access on Palo Alto firewalls but failed against WordPress. Around 22.6 million exposed instances are potentially affected.
Critical PHP flaws CVE-2026-109618 and CVE-2026-109619 now exploited in the wild
Two memory-corruption flaws in PHP, CVE-2026-109618 (out-of-memory handling) and CVE-2026-109619 (use-after-free in global state), allow unauthenticated remote code execution via crafted HTTP requests, with the risk greatest for Apache modphp. CISA added both to its Known Exploited Vulnerabilities catalogue on 26 October 2026, and AWS advises upgrading rather than relying on configuration changes alone.
CISA adds Brotli and Adobe Commerce PolyShell flaws to Known Exploited Vulnerabilities catalogue
CISA added CVE-2026-111497 (Google Brotli, CVSS 9.2) and CVE-2026-48356 (Adobe Commerce and Magento, CVSS 9.3) to its KEV catalogue, with federal agencies told to fix them by October 29, 2026. Sansec reported the Magento flaw, dubbed PolyShell, had been used to infect at least 953 online stores, while exploit traffic for the Brotli flaw has also been observed. Node.js, PHP, Bun and Microsoft .NET have released fixes for Brotli.