Vulnerability · Gitlab Gitlab
CVE-2026-14288
GitLab has remediated an issue in GitLab EE affecting all versions from 17.4 before 19.3.6, 19.4 before 19.4.3, and 19.5 before 19.5.1 that under certain conditions could have allowed an authenticated to bypass a required merge request approval policy on a protected branch due to improper access control during approval rule synchronization.
CVSS score (v3.1)3.1Low
Fixed in 19.3.6
Not on CISA KEV list
Am I affected?
Sign in and add the software you use to your watchlist: we check it against every new vulnerability.
Show me how to fix itTimeline
- Published by NVD
- Last updated by NVD
Affected products
| Product | Versions |
|---|---|
| Gitlab Gitlab | from 17.4.0 to before 19.3.6; from 19.4.0 to before 19.4.3; 19.5.0 only |
Sources: NVD and CISA known exploited vulnerabilities catalogue.