Vulnerability · Gnome Libsoup
CVE-2026-102560
A flaw was found in libsoup. When the permessage-deflate WebSocket extension compresses a very large outgoing message, truncated size calculations used for GByteArray growth could wrap, causing zlib to write past the allocated buffer and resulting in a heap buffer overflow.
CVSS score (v3.1)9.8Critical
Fixed in 3.7.3
Not on CISA KEV list
Am I affected?
Sign in and add the software you use to your watchlist: we check it against every new vulnerability.
Show me how to fix itTimeline
- Published by NVD
- Last updated by NVD
Affected products
| Product | Versions |
|---|---|
| Gnome Libsoup | up to before 3.7.3 |
| Redhat Enterprise Linux | 10.0 only; 7.0 only; 8.0 only; 9.0 only |
Sources: NVD and CISA known exploited vulnerabilities catalogue.