Vulnerability · Gnome Libsoup
CVE-2026-102557
A flaw was found in libsoup. When reassembling fragmented WebSocket messages into a GByteArray, libsoup did not adequately cap total message size against the limits of the underlying buffer type. A remote peer could send fragments that caused size truncation while the implementation still used the full length, leading to heap corruption or a crash.
CVSS score (v3.1)8.6High
Fixed in 3.7.3
Not on CISA KEV list
Am I affected?
Sign in and add the software you use to your watchlist: we check it against every new vulnerability.
Show me how to fix itTimeline
- Published by NVD
- Last updated by NVD
Affected products
| Product | Versions |
|---|---|
| Gnome Libsoup | up to before 3.7.3 |
| Redhat Enterprise Linux | 10.0 only; 7.0 only; 8.0 only; 9.0 only |
Sources: NVD and CISA known exploited vulnerabilities catalogue.